PAT1007


原题

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路

题意:给你一个k个整数的序列,连续子序列定义为 $${N_i, N_{i + 1}, N_{i + 2}, …, N_j}, 1 \leq i \leq j \leq k$$ ,最大子序列是具有最大元素和的连续子序列。例如,给定 $${-2, 11, -4, 13, -5, -2}$$ ,它的最大子序列为 $${11, -4, 13}$$ ,最大和为20。

现在,你应该找到最大子序列和,并且找到最大子序列的第一个元素和最后一个元素。

输入:第一行整数包含一个正整数K,接下来是K个数字,每个数字用空格隔开。

输出:对于每个测试案列,输出最大子序列和,和最大子序列的第一个元素和最后一个。中间用空格隔开,但是最后不要有额外的空格。在案列中,最大子序列和可能不是唯一的,输出一组较小的即可。如果K个数字全是负数,最大子序列和被定义为0,你应该输出K个数字的第一个元素和最后一个。

题解

这是一道求连续子数组的最大和的升级版,不仅仅要我们输出最大子序列和,还要输出最大子序列的第一个元素和最后一个元素。

求连续子数组最大和,一道典型的dp题。

class Solution {
public:
    int maxSubArray(vector<int>& nums) {
        int size = nums.size();
        vector<int> dp(size + 1);
        dp[0] = nums[0];
        int ans = nums[0];
        for (int i = 1; i < size; ++i) {
            dp[i] = max(0, dp[i - 1]) + nums[i];
            ans = max(ans, dp[i]);
        }
        return ans;
    }
};

我们只要在连续子数组和的情况下,加上判断条件,就能得到最大子序列的第一个元素和最后一个。

#include <algorithm>
#include <iostream>
#include <queue>
#include <string>
#include <unordered_map>
#include <vector>

using namespace std;

int main() {
  int k;
  cin >> k;
  vector<int> nums(k);
  for (int i = 0; i < k; ++i) {
    int temp;
    cin >> temp;
    nums[i] = temp;
  }
  vector<int> dp(k + 1);
  dp[0] = nums[0];
  int ans = nums[0];
  int left = 0, right = k - 1, temp = 0;
  for (int i = 1; i < k; ++i) {
    dp[i] = max(0, dp[i - 1]) + nums[i];
    if (dp[i] > ans) {
      ans = dp[i];
      left = temp + 1;
      right = i;
    }
    if (dp[i] < 0) {
      temp = i;
    }
  }
  if (ans < 0) {
    ans = 0;
  }
  cout << ans << " " << nums[left] << " " << nums[right] << endl;
  return 0;
}

文章作者: incipe
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 incipe !
评论
 上一篇
PAT1006 PAT1006
原题 At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one
2020-08-10
下一篇 
PAT1003 迪杰斯特拉(Dijkstra) PAT1003 迪杰斯特拉(Dijkstra)
算法简介迪杰斯特拉(Dijkstra)是从一个顶点到其余各顶点的最短路径算法,解决的是有权图中最短路径问题。迪杰斯特拉算法主要特点是从起始点开始,采用贪心算法的策略,每次遍历到始点距离最近且未访问过的顶点的邻接节点,直到扩展到终点为止。
2020-08-07
  目录